请选择 进入手机版 | 继续访问电脑版

股票家-专业股票论坛

1
4
2
3
2
1
横幅1

[技巧] 大智慧公式:反弹线

[复制链接]

1

主题

1

帖子

13

积分

新手上路

Rank: 1

积分
13
分享到:
发表于 2014-4-11 13:45:00 | 显示全部楼层 |阅读模式


  大智慧公式:反弹线
  var6:=(2*CLOSE+HIGH+LOW)/4;

  var7:=LLV(LOW,13);

  var8:=HHV(HIGH,13);

  var9:=EMA((var6-var7)/(var8-var7)*100,13);

  varA:=EMA(0.667*REF(var9,1)+0.333*var9,2);

  多:var9,COLORRED, LINETHICK0;

  空: EMA(0.382*REF(var9,2)+0.618*var9,12),color00ff00;

  STICKLINE(var9>varA,var9,varA,4,0), COLORRED, LINETHICK2;

  STICKLINE(var9<=varA,var9,varA,4,0), COLORYELLOW ,LINETHICK2;

  cymm:=MA(CLOSE,13)>REF(MA(CLOSE,13),1)*1.004 and MA(CLOSE,1)/MA(CLOSE,241)>1 and MA(CLOSE,1)/MA(CLOSE,241)<1.11,COLORGREEN;

  cymm1:=cymm and FILTER(cymm,7);{过滤7天内再次出现的阳线}

  草原牧马:if(cymm1,50,0),color00ff00;

  一阳三线:if(cross(c,ema(c,55)) and cross(c,ema(c,89)) and cross(c,ema(c,144)),50,0),COLORRED,linethick2;

  va1:=ref((((hhv(h,110)-llv(l,110))/llv(l,110))/llv(l,110)),1)<=(6.4/100) and c>=ref(hhv(h,110),1) and barscount(c)>110;{前110日在上下6.4%的幅度整理并且今日突破}

  突破盘整:if(va1,50,0),COLORFF00FF;

  趋势线:=((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)- 2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50);

  开始反弹: IF(CROSS(趋势线,21),50,0),color0099ff,linethick2;

  ma1:=eMA(CLOSE,5);

  ma2:=eMA(CLOSE,10);

  ma3:=EMA(CLOSE,20);

  ma4:=EMA(CLOSE,30);

  sx:=cross(MA1,MA2) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018

  or cross(MA1,MA4) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018

  or cross(MA2,MA3) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018

  or cross(MA1,MA3) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018,colorff00ff;{三线粘合}

  三线粘合:if(sx,50,0),colorwhite;

  a1:=CLOSE/REF(CLOSE,1)>=1.05 AND HIGH/CLOSE<1.0001 AND MA(CLOSE,90)/CLOSE>=1.15;

  a2:=a1 AND COUNT(a1,20)=1;

  短线快枪:if(a2,50,0),colorffcc66,linethick2;

  stickline(草原牧马>0,15,草原牧马*1.1,1,0),pointdot,colorwhite;

  stickline(草原牧马>0 and 草原牧马<400,30,草原牧马,1,0),colorred,linethick1;

  stickline(草原牧马>0,15,草原牧马*0.6,5,0),color00ff00,linethick5;

  stickline(草原牧马>0,15,草原牧马*0.4,5,0),color00ff00,linethick7;

  stickline(草原牧马>0,15,草原牧马*0.2,5,0),colorff00ff,linethick7;

  stickline(一阳三线>0,15,一阳三线*1.1,1,0),pointdot,colorwhite;

  stickline(一阳三线>0 and 一阳三线<400,30,一阳三线,1,0),coloryellow,linethick1;

  stickline(一阳三线>0,15,一阳三线*0.6,5,0),colorred,linethick5;

  stickline(一阳三线>0,15,一阳三线*0.4,5,0),colorred,linethick7;

  stickline(一阳三线>0,15,一阳三线*0.2,5,0),coloryellow,linethick7;

  stickline(突破盘整>0,15,突破盘整*1.1,1,0),pointdot,colorwhite;

  stickline(突破盘整>0 and 突破盘整<400,30,突破盘整,1,0),colorred,linethick1;

  stickline(突破盘整>0,15,突破盘整*0.6,5,0),colorff00ff,linethick5;

  stickline(突破盘整>0,15,突破盘整*0.4,5,0),colorff00ff,linethick7;

  stickline(突破盘整>0,15,突破盘整*0.2,5,0),colorffcc66,linethick7;

  stickline(开始反弹>0,15,开始反弹*1.1,1,0),pointdot,colorwhite;

  stickline(开始反弹>0 and 开始反弹<400,30,开始反弹,1,0),colorred,linethick1;

  stickline(开始反弹>0,15,开始反弹*0.6,5,0),color0099ff,linethick5;

  stickline(开始反弹>0,15,开始反弹*0.4,5,0),color0099ff,linethick7;

  stickline(开始反弹>0,15,开始反弹*0.2,5,0),color00ff00,linethick7;

  stickline(三线粘合>0,15,三线粘合*1.1,1,0),pointdot,colorwhite;

  stickline(三线粘合>0 and 三线粘合<400,30,三线粘合,1,0),colorred,linethick1;

  stickline(三线粘合>0,15,三线粘合*0.6,5,0),colorwhite,linethick5;

  stickline(三线粘合>0,15,三线粘合*0.4,5,0),colorwhite,linethick7;

  stickline(三线粘合>0,15,三线粘合*0.2,5,0),colorred,linethick7;

  stickline(短线快枪>0,15,短线快枪*1.1,1,0),pointdot,colorwhite;

  stickline(短线快枪>0 and 短线快枪<400,30,短线快枪,1,0),colorred,linethick1;

  stickline(短线快枪>0,15,短线快枪*0.6,5,0),colorffcc66,linethick5;

  stickline(短线快枪>0,15,短线快枪*0.4,5,0),colorffcc66,linethick7;

  stickline(短线快枪>0,15,短线快枪*0.2,5,0),color0099ff,linethick7;

回复

使用道具 举报

使用高级回帖 (可批量传图、插入视频等)快速回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则   Ctrl + Enter 快速发布  

发帖时请遵守我国法律,网站会将有关你发帖内容、时间以及发帖IP地址等记录保留,只要接到合法请求,即会将信息提供给有关政府机构。
快速回复 返回顶部 返回列表