请选择 进入手机版 | 继续访问电脑版

股票家论坛

2
1
4
3
2
1
横幅1

[技巧] 通达信股票公式之dmia

[复制链接]

1

主题

1

帖子

13

积分

新手上路

Rank: 1

积分
13
分享到:
发表于 2014-4-21 16:11:00 | 显示全部楼层 |阅读模式
通达信股票公式之dmia

  {DMIA}

  ATRA := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),6,1);

  HD := HIGH-REF(HIGH,1);

  LD := REF(LOW,1)-LOW;

  DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),6,1);

  DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),6,1);

  PDI:= DMP*100/ATRA;

  MDI:= DMM*100/ATRA;

  ADX: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,6,1),LINETHICK2;

  涨趋势:IF((MDI-PDI)/(MDI+PDI)<0,10,DRAWNULL),COLOR8899DD,NODRAW;

  跌趋势:IF((MDI-PDI)/(MDI+PDI)>=0,10,ADX),COLORDD9988,NODRAW;

  DRAWBAND(ADX,RGB(100,80,110),10,0);

  DRAWBAND(跌趋势,RGB(200,120,230),涨趋势,RGB(180,124,204));

  对比线:=(ADX+REF(ADX,6))/2;

  STICKLINE(CROSS(ADX,30),ADX,30,3,0),COLOR00FFFF,LINETHICK5;

  STICKLINE(C>0,80,80,1.5,0),COLORFFFFFF;

  STICKLINE(C>0,50,50,1.5,0),COLOR00FFFF;

  STICKLINE(C>0,20,20,1.5,0),COLORFF00FF;

  WW1:=SMA(((CLOSE-LLV(CLOSE,10))/(HHV(HIGH,10)-LLV(LOW,10))),3,1);

  WW2:=SMA(((WW1-LLV(WW1,3))/(HHV(WW1,3)-LLV(WW1,3))),3,1)*100;

  ZZ:=SMA(((VOL-LLV(VOL,10))/(HHV(VOL,10)-LLV(VOL,10))),3,1);

  ZZ1:=SMA(((ZZ-LLV(ZZ,3))/(HHV(ZZ,3)-LLV(ZZ,3))),3,1)*100;

  快线:=EMA(WW2,1),COLORBLUE,LINETHICK2;

  慢线:=EMA(快线,2),COLORGREEN,LINETHICK2;

  量快:=EMA(ZZ1,1)COLORWHITE,LINETHICK2;

  量慢:=EMA(量快,2),COLORWHITE,LINETHICK2;

  AA1:=SMA(((CLOSE-LLV(CLOSE,13))/(HHV(HIGH,13)-LLV(LOW,13))),3,1);

  价线:=SMA(((AA1-LLV(AA1,4))/(HHV(AA1,4)-LLV(AA1,4))),3,1)*100;

  周线:MA(价线,5),COLORMAGENTA,LINETHICK1;

  BB1:=SMA(((VOL-LLV(VOL,13))/(HHV(VOL,13)-LLV(VOL,13))),3,1);

  量线:SMA(((BB1-LLV(BB1,4))/(HHV(BB1,4)-LLV(BB1,4))),3,1)*100,NODRAW;

  周量:MA(量线,5),COLORYELLOW,LINETHICK1;

  月线:=MA(价线,22),COLORRED,LINETHICK0;

  月量:=MA(量线,22),COLORYELLOW,LINETHICK0;

  快线2:=EMA(周线,1),COLORBLUE,LINETHICK2;

  慢线2:=EMA(快线2,2),COLORGREEN,LINETHICK2;

  量快2:=EMA(周量,1);

  量慢2:=EMA(量快2,2),COLORWHITE,LINETHICK2;

  DRAWTEXT(FILTER(快线>=95 AND 慢线>=95 AND 周线>=90 OR 周量>=90,5),85,'减');

  看色块→:30,COLORRED;

  IF(周线>=REF(周线,1),周线,DRAWNULL),COLORMAGENTA,LINETHICK2;

  IF(周线>=REF(周线,1) AND 月线>=REF(月线,1),周线,DRAWNULL),COLORRED,LINETHICK2;

  IF(周线<REF(周线,1),周线,DRAWNULL),COLORGREEN,LINETHICK1;

  IF(周量>=REF(周量,1),周量,DRAWNULL),COLORYELLOW,LINETHICK2;

  IF(周量<REF(周量,1),周量,DRAWNULL),COLORGREEN,LINETHICK1;

  IF(CROSS(快线2,慢线2),慢线2,DRAWNULL),COLORRED,LINETHICK3,CIRCLEDOT;

  IF(CROSS(慢线2,快线2),快线2,DRAWNULL),COLORGREEN,LINETHICK3,CIRCLEDOT;

  IF(CROSS(量快2,量慢2),量慢2,DRAWNULL),COLORRED,LINETHICK2,CIRCLEDOT;

  IF(CROSS(量慢2,量快2),量快2,DRAWNULL),COLORLIGREEN,LINETHICK3,CIRCLEDOT;

回复

使用道具 举报

使用高级回帖 (可批量传图、插入视频等)快速回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则   Ctrl + Enter 快速发布  

发帖时请遵守我国法律,网站会将有关你发帖内容、时间以及发帖IP地址等记录保留,只要接到合法请求,即会将信息提供给有关政府机构。
快速回复 返回顶部 返回列表