请选择 进入手机版 | 继续访问电脑版

股票家-专业股票论坛

3
1
4
2
1
2
横幅1

[技巧] 通达信股票公式之三线开花指标

[复制链接]

1

主题

1

帖子

13

积分

新手上路

Rank: 1

积分
13
分享到:
发表于 2014-4-21 16:15:00 | 显示全部楼层 |阅读模式
通达信股票公式之三线开花指标

  三线开花,虽然很多人懂,但真正会应用的有几个。

  请看原码。谁有选股公式,请奉上。出现“牛象”,或“买点”时。见图。

  MA20:MA(C,20),COLORWHITE,LINETHICK2;

  MA120:MA(C,120),COLORFFCCCC,LINETHICK2;

  MA250:MA(C,250),COLORFFCC66,LINETHICK2;

  乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;

  TT1:=CROSS(MA20,MA120) AND CROSS(MA20,MA250) AND V>REF(V,1);

  TT2:=MA20>REF(MA20,2) AND V>REF(V,1) AND CROSS(C,MA20);

  STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;

  DRAWTEXT(TT1,L-0.13,'金叉'),COLORYELLOW;

  STICKLINE(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L,L-0.09,4,0),COLORYELLOW;

  DRAWTEXT(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L-0.13,'并线开花'),COLORYELLOW;

  STICKLINE(TT2,L,L-0.09,4,0),COLORYELLOW;

  DRAWTEXT(TT2,L-0.13,'买点1'),COLORYELLOW;

  STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;

  DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),COLOR00FF00;

  STICKLINE(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L,L-0.09,4,0),COLORFFCC66;

  DRAWTEXT(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L-0.13,'牛象'),COLORFFCC66;

  STICKLINE(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L,L-0.09,4,0),COLORFF00FF;

  DRAWTEXT(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.13,'买点2'),COLORFF00FF ;

  A1:=SUM(AMOUNT,3)/SUM(VOL,3)/100;

  A2:=SUM(AMOUNT,8)/SUM(VOL,8)/100;

  A3:=SUM(AMOUNT,21)/SUM(VOL,21)/100;

  DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));

  DEA:=EMA(DIFF,9);

  MACD:=2*(DIFF-DEA);

  V1:=C-(A1+MA(C,3))/2;

  V2:=C-(A2+MA(C,8))/2;

  V3:=C-(A3+MA(C,21))/2;

  VA1:=(C+V3-V1+MACD);

  VA4:=(C+V2-V1+MACD);

  短线:EMA(VA1,6),LINETHICK2,COLORYELLOW;

回复

使用道具 举报

使用高级回帖 (可批量传图、插入视频等)快速回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则   Ctrl + Enter 快速发布  

发帖时请遵守我国法律,网站会将有关你发帖内容、时间以及发帖IP地址等记录保留,只要接到合法请求,即会将信息提供给有关政府机构。
快速回复 返回顶部 返回列表