请选择 进入手机版 | 继续访问电脑版

股票家论坛

3
1
2
4
2
1
横幅1

[技巧] 通达信股票公式之KDJ、MACD金叉共振

[复制链接]

1

主题

1

帖子

13

积分

新手上路

Rank: 1

积分
13
分享到:
发表于 2014-4-21 16:15:00 | 显示全部楼层 |阅读模式
通达信股票公式之KDJMACD金叉共振

  DIFEMA(CLOSE,12)-EMA(CLOSE,26))*100;

  DEA:EMA(DIF,9);

  MACDDIF-DEA)*2,COLORSTICK;

  DRAWICON(CROSS(DIF,DEA),DEA,1);

  DRAWICON(CROSS(DEA,DIF),DEA,2);

  IF(DIF<DEA,DIF,DRAWNULL),COLORGREEN;

  DD:=C=HHV(C,180);

  EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;

  CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;

  顶背离:=(DD AND EE AND DEA< HHV(DEA,180))*DEA;

  A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

  {顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);}

  DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORRED,LINETHICK2;

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:SMA(RSV,9,3),COLORYELLOW;

  D:SMA(K,9,3),COLORWHITE;

  J:3*K-2*D,COLORMAGENTA;

  IF(J<D,J,DRAWNULL),COLORFFEE44;

  0,COLORRED,LINETHICK2;20,COLORLIMAGENTA;{50,COLORWHITE;}

  80,COLORBLUE;100,COLORGREEN,LINETHICK2;

  DRAWTEXT(ISLASTBAR,0,'高安全区'),COLORRED;

  DRAWTEXT(ISLASTBAR,20,'安 全 区'),COLORLIMAGENTA;

  DRAWTEXT(ISLASTBAR,80,'风 险 区'),COLORBLUE;

  DRAWTEXT(ISLASTBAR,100,'高风险区'),COLORGREEN;

  A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

  B1:=REF(C,A1+1)>C AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA);

  A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

  B2:=REF(C,A22+1)>C AND REF("KDJ.K"(9,3,3),A22+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

  A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

  B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

  DRAWTEXT(B1,DEA-0.20,'▲MACD底背'),COLORWHITE;

  DRAWTEXT(B2,D-0.20,'●KDJ底背'),COLORFF00FF;

  {DJ:=CROSS(J,D) AND D<20;

  DRAWTEXT(DJ,J-0.3,'低金叉'),COLORCYAN;

  MDJ:=CROSS(DIF,DEA) AND DEA<0;

  DRAWTEXT(MDJ,DEA-0.3,'低金叉'),COLORGREEN;

  DRAWTEXT(CROSS(DEA,DIF),DIF+0.3,'死叉'),COLORYELLOW;

  DRAWTEXT(CROSS(D,J),J+0.3,'死叉'),COLORRED;}

  A:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);

  DRAWICON(A,LOW*0.98,1);

  B4:CROSS(DIF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

  DRAWTEXT(B4,L-0.20,'★金叉共振'),COLOR0099FF;

  DRAWICON(CROSS(K,D),D,1);

  DRAWICON(CROSS(D,K),D,2);

  BA:=DEA>REF(DEA,1);

  BB:=SUM(BA,5)>=4;

  BC:=C<O;

  BD:=SUM(BC,5)>=2;

  BXG:FILTER(BB AND BD AND J>REF(J,1) AND REF(J,1)<REF(J,2),3);

  STICKLINE(BXG,HHV(J,60),HHV(J,60)-20,1,0),COLORRED;

  SS:=EMA(C,11);

  LL:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,5))/4;

  AA:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10));

  (CROSS(AA,0.05)-1);

回复

使用道具 举报

使用高级回帖 (可批量传图、插入视频等)快速回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则   Ctrl + Enter 快速发布  

发帖时请遵守我国法律,网站会将有关你发帖内容、时间以及发帖IP地址等记录保留,只要接到合法请求,即会将信息提供给有关政府机构。
快速回复 返回顶部 返回列表