请选择 进入手机版 | 继续访问电脑版

股票家-专业股票论坛

2
1
4
3
1
2
横幅1

[技巧] 大智慧股票公式之精准顶底判断副图公式源码

[复制链接]

1

主题

1

帖子

13

积分

新手上路

Rank: 1

积分
13
分享到:
发表于 2014-4-22 11:00:00 | 显示全部楼层 |阅读模式


  大智慧股票公式之精准顶底判断副图公式源码
  SVAR0:=MA(CLOSE,20) ;

  SVAR1:=SVAR0 + 2 * STD(CLOSE,20) ;

  SVAR2:=SVAR0 - 2 * STD(CLOSE,20) ;

  SVAR3:=(CLOSE - SVAR2) / (SVAR1 - SVAR2) * 100 ;

  SVAR4:=(HIGH - SVAR2) / (SVAR1 - SVAR2) * 100 ;

  SVAR5:=(LOW - SVAR2) / (SVAR1 - SVAR2) * 100 ;

  底部:0,COLORFF0000 ;

  强弱:50,POINTDOT,COLOR00FFFF ;

  顶部:100,COLORFF0000 ;

  F1:SVAR5 ;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),0,0),COLOR00FF00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),8,0),COLOR008800;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),7,0),COLOR009900;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),6,0),COLOR00AA00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),5,0),COLOR00BB00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),4,0),COLOR00CC00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),3,0),COLOR00DD00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),2,0),COLOR00EE00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR3,REF(SVAR3,1),1,0),COLOR00FF00;

  STICKLINE(REF(SVAR3,1) >= SVAR3,SVAR4,SVAR5,1,0),COLOR00FF00;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),0,0),COLORFFBBFF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),8,0),COLORFF00FF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),7,0),COLORFF22FF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),6,0),COLORFF44FF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),5,0),COLORFF66FF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),4,0),COLORFF88FF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),3,0),COLORFF99FF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),2,0),COLORFFAAFF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR3,REF(SVAR3,1),1,0),COLORFFBBFF;

  STICKLINE(SVAR3 >= REF(SVAR3,1),SVAR4,SVAR5,1,0),COLORFFBBFF;

  SVAR6:=LLV(LOW,12) ;

  SVAR7:=HHV(HIGH,12) ;

  SVAR8:=EMA((CLOSE - SVAR6) / (SVAR7 - SVAR6) * 100,3) ;

  SVAR9:=EMA(SVAR8,3) ;

  SVAR10:=MA(SVAR9,3) ;

  SVAR11:=3 * SVAR9 - 2 * SVAR10 ;

  SVAR16:=LLV(LOW,45) ;

  SVAR17:=HHV(HIGH,45) ;

  SVAR18:=(CLOSE - SVAR16) / (SVAR17 - SVAR16) * 100 ;

  SVAR19:=SMA(SVAR18,3,1) ;

  SVAR20:=SMA(SVAR19,3,1) ;

  SVAR21:=3 * SVAR19 - 2 * SVAR20 ;

  SVAR22:=SMA(SVAR21,3,1) ;

  SVAR23:=SMA(SVAR22,3,1) ;

  DRAWICON(SVAR19 <= 10 AND CROSS(SVAR19,SVAR20),5,1);

  DRAWICON(SVAR19 >= 90 AND CROSS(SVAR20,SVAR19),95,2);

  SVAR24:=SMA(3 * SMA((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30)) * 100,5,1) - 2 * SMA(SMA((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30)) * 100,5,1),3,1),3,1) ;

  DRAWGBK(SVAR24 >= 90,STRIP( RGB(80,0,80),RGB(80,0,80),2));

  DRAWGBK(SVAR24 <= 10,STRIP( RGB(0,80,80),RGB(0,80,80),2));

  SVAR25:=1 ;

  SVAR26:=MA(100 * (CLOSE - LLV(CLOSE,34)) / (HHV(HIGH,34) - LLV(LOW,34)),5) - 20 ;

  SVAR27:=2 * ABS(SVAR26) ;

  SVAR28:=100 - (100 - 3 * SMA((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55)) * 100,20,1) + 2 * SMA(SMA((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55)) * 100,20,1),15,1)) ;

  SVAR29:=100 - (100 - 3 * SMA((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55)) * 100,20,1) + 2 * SMA(SMA((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55)) * 100,20,1),15,1)) ;

  SVAR30:=(HIGH + LOW + CLOSE) / 3 ;

  SVAR31:=(SVAR30 - MA(SVAR30,10)) / (0.015 * AVEDEV(SVAR30,10)) ;

  SVAR32:=(SVAR30 - MA(SVAR30,30)) / (0.015 * AVEDEV(SVAR30,30)) ;

  SVAR33:=IF(SVAR31 >= 150 AND SVAR31 < 200 AND SVAR32 >= 150 AND SVAR32 < 200,10,0) ;

  SVAR34:=IF(SVAR31 <= 0 - 150 AND SVAR31 > 0 - 200 AND SVAR32 <= 0 - 150 AND SVAR32 > 0 - 200,0 - 10,SVAR33) * SVAR25 ;

  SVAR35:=(CLOSE - MA(CLOSE,13)) / MA(CLOSE,13) * 100 ;

  SVAR36:=100 - ABS(SVAR35) ;

  SVAR37:=3 * SMA((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55)) * 100,20,1) - 2 * SMA(SMA((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55)) * 100,20,1),15,1) ;

  SVAR38:=3 * SMA((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55)) * 100,20,1) - 2 * SMA(SMA((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55)) * 100,20,1),15,1) ;

  SVAR39:=REF(LOW,1) * 0.9 ;

  SVAR40:=LOW * 0.9 ;

  SVAR41:=(SVAR40 * VOL + SVAR39 * (CAPITAL - VOL)) / CAPITAL ;

  SVAR42:=EMA(SVAR41,30) ;

  SVAR43:=SVAR42 - CLOSE ;
  SVAR44:=REF(CLOSE,1) ;

  SVAR45:=SMA(MAX(CLOSE - SVAR44,0),7,1) / SMA(ABS(CLOSE - SVAR44),7,1) * 100 ;

  SVAR46:=SMA(MAX(CLOSE - SVAR44,0),13,1) / SMA(ABS(CLOSE - SVAR44),13,1) * 100 ;

  SVAR47:=BARSCOUNT(CLOSE) ;

  SVAR48:=SMA(MAX(CLOSE - SVAR44,0),6,1) / SMA(ABS(CLOSE - SVAR44),6,1) * 100 ;

  SVAR49:=((0 - 100) * (HHV(HIGH,60) - CLOSE) / (HHV(HIGH,60) - LLV(LOW,60)) + 50) * 2 ;

  SVAR50:=(CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15)) * 100 ;

  SVAR51:=(SMA(SVAR50,4,1) - 50) * 2 ;

  SVAR52:=SMA(SVAR51,3,1) ;

  SVAR53:=(INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14)) * 100 ;

  SVAR54:=SMA(SVAR53,4,1) ;

  SVAR55:=SMA(SVAR54,3,1) ;

  SVAR56:=(HHV(HIGH,30) - CLOSE) / CLOSE * 100 ;

  SVAR57:=IF(SVAR48 <= 25 AND SVAR49 < 0 - 95 AND SVAR56 > 20 AND SVAR52 < 0 - 30 AND SVAR55 < 30 AND SVAR43 >= 0 - 0.25 AND SVAR45 < 22 AND SVAR46 < 28 AND SVAR47 > 50,80,0) * SVAR25 ;

  空方:0 - IF(SVAR26 < 0,SVAR27,0) * SVAR25,COLORAAAAAA ;

  0 - 40;

  SVAR58:=HHV(SVAR30,14) ;

  SVAR59:=LLV(SVAR30,14) ;

  SVAR60:=SVAR58 - SVAR59 ;

  SVAR61:=EMA((SVAR30 - SVAR59) / SVAR60,2) * 100 ;

  SVAR62:=HHV(SVAR30,30) ;

  SVAR63:=LLV(SVAR30,30) ;

  SVAR64:=SVAR62 - SVAR63 ;

  SVAR65:=EMA((SVAR30 - SVAR63) / SVAR64,2) * 100 ;

  SVAR66:=HHV(SVAR30,55) ;

  SVAR67:=LLV(SVAR30,55) ;

  SVAR68:=SVAR66 - SVAR67 ;

  SVAR69:=EMA((SVAR30 - SVAR67) / SVAR68,2) * 100 ;

  SVAR70:=SVAR61 - 50 ;

  SVAR71:=SVAR65 - 50 ;

  SVAR72:=SVAR69 - 50 ;

  DRAWICON(CROSS(SVAR58,0),0,4);

  SVAR73:=SMA((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30)) * 100,3,1) ;

  SVAR74:=SMA(SVAR73,3,1) ;

  SVAR75:=EMA(CLOSE,5) ;

  SVAR76:=SMA(MAX(CLOSE - SVAR75,0),6,1) / SMA(ABS(CLOSE - SVAR75),6,1) * 100 ;

  SVAR77:=SMA(MAX(CLOSE - SVAR75,0),3,1) / SMA(ABS(CLOSE - SVAR75),3,1) * 100 ;

  SVAR78:="KDJ.D"(18,5,6) ;

  SVAR79:=(MA(AMOUNT,5) / MA(VOL,5) / 100 - MA(AMOUNT,110) / MA(VOL,110) / 100) / (MA(AMOUNT,5) / MA(VOL,5) / 100) < 0 - 0.273 ;

  SVAR80:=(CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9)) * 100 ;

  SVAR81:=(CLOSE - MA(CLOSE,30)) / MA(CLOSE,30) < 0 - 0.125 ;

  SVAR82:=SVAR79 AND SVAR81 ;

  SVAR83:=EMA(WINNER(CLOSE) * 100,3) ;

  SVAR84:=EMA(CLOSE,3) ;

  SVAR85:=SMA(MAX(CLOSE - SVAR84,0),6,1) / SMA(ABS(CLOSE - SVAR84),6,1) * 100 ;

  SVAR86:=MA(SVAR85,10) ;

  优化牛A:IF(SVAR81 AND SVAR85 < 3,0 - 40,0) * SVAR25,LINETHICK2,COLOR3399FF ;

  优化牛B:IF(SVAR81 AND SVAR86 < 9,0 - 38,0) * SVAR25,LINETHICK2,COLOR3399FF ;

  优化剑:FILTER(SVAR85 < 6 AND SVAR82,35) * 1,STICK,LINETHICK2,COLORFF0000 ;

  DRAWICON(优化剑 > 0,1,1);

  优化牛3:IF(SVAR83 < 1.5 AND SVAR86 < 21 AND SVAR85 < 5.5,80,0) * SVAR25,LINETHICK2,COLOR3399FF ;

  SVAR87:=1050431 ;

  SVAR88:=IF(DATE <= SVAR87,1,0) ;

  SVAR89:=MA(CLOSE,80) - MA(CLOSE,13) / 3 ;

  SVAR90:=MA((CLOSE - SVAR89) / SVAR89,1) ;

  SVAR91:=IF(CROSS(SVAR90,0) AND LOW / REF(HIGH,1) < 1.012,0.5,0) ;

  SVAR92:=IF((COUNT(SVAR90 > REF(SVAR90,1),3) = 3) AND (COUNT(SVAR90 < 0,10) = 10) AND (REF(SVAR90,3) = LLV(SVAR90,10)),0.5,0) ;

  SVAR93:=IF((REF(SVAR90,2) = LLV(SVAR90,20)) AND REF(SVAR90,2) < 0.071 AND REF(SVAR90,2) < REF(SVAR90,1) AND NOT(REF(LOW,1) > REF(HIGH,2) AND LOW > REF(HIGH,1)) AND CLOSE > SVAR44,0.5,0) ;

  SVAR94:=EMA(SVAR90,12) * 0.7 ;

  SVAR95:=EMA(SVAR90,3) ;

  优化底部将成:IF(LLV(SVAR95 - SVAR94,5) > 0,0,0 - 40) * SVAR88,COLORFFCC66 ;

  SVAR12:=SMA(SVAR11,3,1) ;

  SVAR13:=SMA(SVAR12,3,1) ;

  SVAR14:=SVAR13 >= REF(SVAR13,1) ;

  SVAR15:=SVAR13 <= REF(SVAR13,1) ;

  SVAR12:=3 * SVAR73 - 2 * SVAR74 ;

  优化动力线:EMA(SVAR12,6) * SVAR25,LINETHICK0,COLOR00FFFF ;

  优化虎:IF(优化动力线 < 15.5 AND 空方 < 0 - 30 AND SVAR78 < 35 AND SVAR76 < 10 AND SVAR77 < 6.5 AND SVAR70 < 0 - 47 AND SVAR71 < 0 - 47 AND SVAR72 < 0 - 48.5,100,0),LINETHICK2 ;

  优化牛:IF(空方 < 0 - 38 AND 优化虎 > 0,100,0) * SVAR25,LINETHICK2 ;

  PARTLINE(SVAR13,SVAR14,RGB(255,0,0),SVAR15,RGB(0,255,0)),LAYER0 ;

回复

使用道具 举报

使用高级回帖 (可批量传图、插入视频等)快速回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则   Ctrl + Enter 快速发布  

发帖时请遵守我国法律,网站会将有关你发帖内容、时间以及发帖IP地址等记录保留,只要接到合法请求,即会将信息提供给有关政府机构。
快速回复 返回顶部 返回列表